WTF ... IS WTF!?
We are a collective of people who believe in freedom of speech, the rights of individuals, and free pancakes! We share our lives, struggles, frustrations, successes, joys, and prescribe to our own special brand of humor and insanity. If you are looking for a great place to hang out, make new friends, find new nemeses, and just be yourself, WTF.com is your new home.

Firefox

Brain Spout

Wizard No More
4,503
102
177
#1
okay, so i log onto my computer today and firefox loads up and all my bookmarks are gone... :smash:

so i keep trying to restart firefox so that it will prompt me to select user profile (or whatever it's called), but i can't get it to do that. hopefully it didn't randomly delete all my bookmarks
 

Slacker

Postaholic
3,735
139
127
#2
I have firefox and i have never had that problem before.
 

Brain Spout

Wizard No More
4,503
102
177
#3
i just used system restore to yesterday when this wasn't happening and it didn't fix the problem. i hope it's just it just hasn't loaded the correct profile for whatever reason, if not...

EDIT: i swear firefox is fucking with me for some reason. i just got back on my comp and it won't even launch firefox, and when i hit ctrl+alt+delete to try to end the process it keeps appearing and disapearing, it's like playing a twitch game trying to end the process (i wasnt able too btw). then i restart my computer and now it wont launch and hitting ctrl alt delte does nothing. im on IE right now.

oh yeh, i figured out how to switch which profile im using, there is only one to choose from and i chose it and my favorites are still gone.

EDIT 2: i undid my system restore and firefox started fien, but still no favorites. i think they are gone for good. im just going ot try to refind all those websites.
 

Jung

???
Premium
13,979
1,397
487
#4
WizardlyFriend said:
so i keep trying to restart firefox so that it will prompt me to select user profile (or whatever it's called), but i can't get it to do that. hopefully it didn't randomly delete all my bookmarks
For future reference, you can start the profile manager by typing firefox.exe -ProfileManager from run.
WizardlyFriend said:
i just used system restore to yesterday when this wasn't happening and it didn't fix the problem. i hope it's just it just hasn't loaded the correct profile for whatever reason, if not...
System restore is only for system files, it won't recover program or filesystem states.
EDIT: i swear firefox is fucking with me for some reason. i just got back on my comp and it won't even launch firefox, and when i hit ctrl+alt+delete to try to end the process it keeps appearing and disapearing, it's like playing a twitch game trying to end the process (i wasnt able too btw). then i restart my computer and now it wont launch and hitting ctrl alt delte does nothing. im on IE right now.
If the taskman ever fails to kill and app, you can access the low level command via command prompt. Try running tasklist to list processes, then taskkill /PID /F to forcfully kill a process. Replace PID with the actual process id of course.
i undid my system restore and firefox started fien, but still no favorites. i think they are gone for good. im just going ot try to refind all those websites.
Try looking in your profile folder for bookmarks.html. Your profile is located in %appdata%\Mozilla\Firefox\Profiles. Just paste that into run. The randomly named folder is your profile, open that and your bookmarks should be there See if you can open them in a browser or editor to confirm that they exist. If the do exist, you can try re-importing them.

Also, the Bookmark Syncronizer extension might be something you want to check out. It's pretty awesome provided you have an FTP account. UNfortunately it doesn't work with Deer Park or nightly builds. :(
 

Brain Spout

Wizard No More
4,503
102
177
#5
i tried looking in my profile, i think for whatever reason they just vanished, maybe i did something. very odd
 

Jung

???
Premium
13,979
1,397
487
#6
I'd create a new profile, that only happens when they get corrupted. Have you added any new extensions or themes lately? They are pretty much the only reason profiles get corrupted. If not I'd check MozillaZine to see if there are any known conflicts with your extensions.

I don't even bother with local bookmarks anymore, it's all about http://del.icio.us and the posting extension.
 

Brain Spout

Wizard No More
4,503
102
177
#7
junglizm said:
I'd create a new profile, that only happens when they get corrupted. Have you added any new extensions or themes lately? They are pretty much the only reason profiles get corrupted. If not I'd check MozillaZine to see if there are any known conflicts with your extensions.

I don't even bother with local bookmarks anymore, it's all about http://del.icio.us and the posting extension.
ill have to try that. i had upwards of 200 links, i probably didn't use a bunch, but occassionally ill need to reference a site.

thanks
 

Brain Spout

Wizard No More
4,503
102
177
#8
i just remembered now as i went ot do a virus search that i think that i may have deleted the files because it thought they were viruses or something. i just remembered that last time i did it which was not too long before i had this problem that i okayed to delete a couple of files, mainly because i was too tired/lazy to check if they wre important, i guess they sort of were...
 

Descent

Hella Constipated
7,686
109
157
#9
WizardlyFriend said:
okay, so i log onto my computer today and firefox loads up and all my bookmarks are gone... :smash:

so i keep trying to restart firefox so that it will prompt me to select user profile (or whatever it's called), but i can't get it to do that. hopefully it didn't randomly delete all my bookmarks
I'm having an issue where when i tell it to save to a hard disk it says "THERE IS NO DISK IN THE DRIVE" and my floppy flips it's shit, and I have to press cancel 12 times.

So I went into Device Manager and disabled my floppy disk controller :thumbsup:. Never use it anyway.

And I've never seen anything like that in my life. I tried reinstalling and it did no good. Time to nuke Windows and put on the non service packed version of 2K3, I guess.
 

Fire_ze_Missles

Martha Fuckin' Stewart
1,622
5
38
#10
I upgraded to FireFox 1.0.6 and got the dreaded, "connection refused" bug. I rolled back to 1.0.4 and will wait for 1.0.7+. :thumbsup:
 

Jung

???
Premium
13,979
1,397
487
#11
WizardlyFriend said:
i just remembered now as i went ot do a virus search that i think that i may have deleted the files because it thought they were viruses or something. i just remembered that last time i did it which was not too long before i had this problem that i okayed to delete a couple of files, mainly because i was too tired/lazy to check if they wre important, i guess they sort of were...
I've never heard of any anti-virus application that would think .html files are viruses.


I couldn't find the BugZilla listing, but this is a know problem with 1.0.4.(I think, could be more versions) Here's a solution if anyone else is having this problem: http://forums.mozillazine.org/viewtopic.php?p=1373361.


On a side note, I'm running Deer Park Alpha 2 and I've yet to have any problems. If anyone is interested, DP2's codebase is what will become Firefox 1.5. It's also noticeably faster than the 1.0.x code base. :cool:
 

Brain Spout

Wizard No More
4,503
102
177
#12
junglizm said:
I've never heard of any anti-virus application that would think .html files are viruses.


I couldn't find the BugZilla listing, but this is a know problem with 1.0.4.(I think, could be more versions) Here's a solution if anyone else is having this problem: http://forums.mozillazine.org/viewtopic.php?p=1373361.


On a side note, I'm running Deer Park Alpha 2 and I've yet to have any problems. If anyone is interested, DP2's codebase is what will become Firefox 1.5. It's also noticeably faster than the 1.0.x code base. :cool:
perhaps, it just occured ot me that i did delete files without giving any thought to them and that they could have been it. the folder they were in had a familiar ring... you're probably right